DHCP no reply received

This forum discusses topics about the Ultimate Deployment Appliance

Moderators: the_dude, Posters

DHCP no reply received

Postby Ozzy » Fri Jun 13, 2008 9:45 pm

Hi,

I have read the posts regarding similar problems on VMWare Community and on this site but none of the solutions have helped me with this. The host I'm trying to build gets an IP from DHCP and shows the pxe menu however when I choose my template, it goes into the text base installation. When i do Alt + F3, the error is
"sending dhcp request through device eth0
waiting for link...
15 seconds
pump told us: no dhcp reply received"

I am using HP ProLiant DL585 G2 as the ESX host to be configured, UDA is running on another similar host as a virtual machine in the same subnet, and a CISCO main switch. I checked the error logs and any other logs to get any cues how to fix it but haven't found anything. I have two cables hooked up to it, one for the service console for the host and another one is for the ILO. When I do ifconfig -a, it sees the eth0 as active and that's the nic it uses to get the first ip to boot to the pxe menu. My dhcp configuration from Web Interface is the following:

ddns-update-style ad-hoc;
next-server 10.0.0.104;

if substring ( option vendor-class-identifier, 0, 9) = "PXEClient"
{
filename "pxelinux.0";
next-server 10.0.0.104;
}

subnet 10.0.0.0 netmask 255.255.255.0 {
option routers 10.0.0.240;
option domain-name-servers 10.0.0.253;
range 10.0.0.70 10.0.0.75;
max-lease-time 300;
}

I am pretty sure the settings here are correct except the subnet 10.0.0.0(not sure what this can be beside 10.0.0.0)
I have tried changing the boot parameters to append ip=dhcp ksdevice=eth0,eth1,eth2,eth3,eth4, link with different configurations for the network settings in the ks.cfg file for the host. I have also tried using nfs share to get the ks.cfg file but no luck there either. I have disabled the dhcp on uda and enabled it on a Windows 2003 server as well but that didn't help either.

Please let me know if there is a way to get the second dhcp request to work so it can see my ks.cfg file. Any help is apprecaiated.

Thanks,
Oz
Ozzy
 
Posts: 3
Joined: Tue Jun 03, 2008 11:36 pm

Return to Ultimate Deployment Appliance

Who is online

Users browsing this forum: No registered users and 0 guests

cron